Category Archives for Server

Fehler bei der Postfach Migration – TooManyLargeItemsPermanentException

Die Migration eines Postfaches von Exchange 2013 nach Exchange Online (Microsoft 365) in einer Hybrid-Umgebung verlief nicht reibungslos, und ein spezifischer Fehler tauchte auf:

Fehler: TooManyLargeItemsPermanentException: Error: This mailbox encountered 2 large items, which exceeds the maximum number (0) of large items that were specified for this request.

Die Ursache des Fehlers waren zwei Elemente. Diese zwei Elemente waren größer als das festgelegte Limit von 150 MB.

Um diesen Fehler zu beheben, stehen zwei Optionen zur Verfügung:

  1. Identifizieren und löschen
    Der Benutzer selber identifiziert und löscht selbstständig die betroffenen Elemente.
  2. Anpassen des Migrationsbatches
    Die zweite Möglichkeit ist die Anpassung des Migrationsbatch.

In diesem speziellen Fall wurde der Fehler behoben, indem die Einstellungen des Migrationsbatches angepasst wurden. Ursprünglich war kein Wert für die Max. Elementgröße angegeben. Dies führte dazu, dass der Batch abbrach, wenn es mehr als 0 Elemente gab, die größer als 150 MB waren.

Die Lösung bestand darin, diese Einstellung zu korrigieren und den Migrationsbatch erneut zu starten. Nach der Anpassung der Max. Elementgröße konnte der Batch erfolgreich durchgeführt werden.

Diese Erfahrung unterstreicht die Bedeutung der genauen Konfiguration von Migrationsparametern, insbesondere wenn es um die Handhabung von großen Elementen geht. Das Identifizieren und Löschen von zu großen Elementen kann eine zeitaufwändige Aufgabe sein, daher kann die Anpassung des Migrationsbatches eine effizientere Lösung sein, um die Migration ohne Komplikationen abzuschließen. Es ist entscheidend, die Parameter im Blick zu behalten und bei Bedarf entsprechende Anpassungen vorzunehmen, um einen reibungslosen Ablauf sicherzustellen.

Empfangsconnector in Exchange 2013 erlauben externe E-Mails zu verschicken

In Exchange 2013 können Empfangsconnectoren (Receive Connectors) eingerichtet werden um beispielsweise Applikationen oder Geräten wie Kopierern oder Scannern den E-Mail-Versand zu ermöglichen.

Da dies auch ohne Authentifizierung möglich ist, dürfen über Empfangsconnectoren im Standard nur E-Mails an interne Empfänger verschickt werden.

Versucht man eine E-Mail an externe Empfänger zu schicken, bekommt man die folgende Fehlermeldung vom Exchange zurück:

5.7.1 Unable to relay

Um auch externe E-Mails verschicken zu können, muss der Empfangsconnector über die Exchange Powershell angepasst werden.

Das macht man mit dem Befehl:

Get-ReceiveConnector "Anonymous Relay" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "Ms-Exch-SMTP-Accept-Any-Recipient"

„Anonymous Relay“ ist in diesem Beispiel der Name des Empfangsconnector. Den genauen Namen des Empfangsconnector bzw. ReceiveConnector kann man mit dem Befehl

Get-ReceiveConnector

auslesen. Hat man mehrere Exchange-Server im Einsatz muss der Servername vor den Connector geschrieben werden.

Achtung bei DEUTSCHEN Exchange-Servern:

Microsoft hat bei den Powershell-Befehlen die Berechtigungen eingedeutscht, was zur Folge hat, dass der User „NT AUTHORITY\ANONYMOUS LOGON“ auf deutschen Exchange-Servern nicht bekannt ist. Hier heißt er „NT-AUTORITÄT\ANONYMOUS-ANMELDUNG“.

Auf deutschen Exchange-Servern muss der Befehl dementsprechend so lauten:

Get-ReceiveConnector "Anonymous Relay" | Add-ADPermission -User "NT-AUTORITÄT\ANONYMOUS-ANMELDUNG" -ExtendedRights "Ms-Exch-SMTP-Accept-Any-Recipient"

Ist der Befehl ausgeführt, können über diesen Connector E-Mails an externe Empfänger geschickt werden.

ACHTUNG: Der Exchange-Server ist jetzt ein „Offenes Relay“. Deshalb den Empfangs-Connector immer nur für den benötigten Server (über die IP-Adresse) berechtigen.

Exchange 2013 – OWA und ECP zeigen leere Seite nach Login

Nach dem Neustart eines Exchange 2013 Servers ist der Zugriff auf OWA und ECP nicht mehr möglich. Es erscheint zwar noch die Login-Seite, nach der Anmeldung bleibt die Seite aber leer bzw. weiss.

Auch Outlook lässt sich nicht mehr starten. Es erscheint die Fehlermeldung, dass der Informationsspeicher nicht zur Verfügung stehe.

Die Dienste sind aber alle gestartet.

In der Ereignisanzeige bzw. Event Log wird im Sekundentakt die folgende Fehlermeldung generiert:

Bei der Verwendung der SSL-Konfiguration für den Endpunkt 0.0.0.0:444 ist ein Fehler aufgetreten. Der Fehlerstatuscode ist in den zurückgegebenen Daten enthalten. Ereignis-ID: 15021

Ereignis ID 15021 - Bei der Verwendung der SSL-Konfiguration für den Endpunkt 0.0.0.0:444 ist ein Fehler aufgetreten.

Die Lösung findet sich im IIS (Internet Information Server / Service):

In der Backend-Site des Exchange im IIS fehlt die Zuordnung des SSL-Zertifikats.

Um den Fehler zu beheben, öffnen wir den IIS-Manager und öffnen auf der linken Seite unter dem Punkt Sites das Exchange Back End.

Auf der rechten Seite sehen wir im Aktionen-Menü den Punkt Bindungen unter Site bearbeiten und klicken darauf.

Exchange Back End im IIS-Manager

In den Sitebindungen wählen wir https mit dem Port 444 aus und klicken auf bearbeiten.

Site-Bindung für Port 444 (https)

Es öffnet sich die Box Sitebindung bearbeiten. Es ist zu sehen, dass kein SSL-Zertifikat ausgewählt ist. Das SSL-Zertifikat wird nun ausgewählt und der Dialog mit OK geschlossen und bestätigt.

SSL-Zertifikat auswählen

Anschließend muss der IIS noch neu gestartet werden. Dann sollte das Problem der Vergangenheit angehören.

1 2 3 9